retroccn
Posts: 4
Joined: 25 Nov 2019, 17:58

Mega SD cart won't boot to menu (black screen)

25 Nov 2019, 18:11

My Mega SD cart will no longer boot to the menu screen. I get the "produced by or under license from Sega" prompt but after that just a black screen. The green LED light is still on, but nothing comes up.

I updated my firmware by downloading my update and renaming the file "_____forced.upd" and so I was able to update, however nothing on the screen ever came up during or after that process. I reset the settings by creating a file called "reset.cfg" at the root of my sd card. The LED light blinked, indicating that the reset took effect. However, same thing again, the Mega SD menu never came up. I tried using three different Genesis hardware units and the same thing occurs each time. Using official Model 1 with official power supply.

Any ideas?

Steven
Posts: 40
Joined: 24 Oct 2019, 18:04
Location: Tokyo

Re: Mega SD cart won't boot to menu (black screen)

28 Nov 2019, 12:46

"No longer" implies that it did work previously. What did you change before it stopped working? Did you try updating it because it stopped working or did it stop working after the update? Different SD card?

I find that I get a similar problem on rare occasions if I remove and reinsert the SD card. A power cycle, removing and reinserting the SD card/the cart itself, or sometimes running Ultracore (I usually use the Mega Sg, not my Mega Drive) generally fix it.

retroccn
Posts: 4
Joined: 25 Nov 2019, 17:58

Re: Mega SD cart won't boot to menu (black screen)

28 Nov 2019, 13:32

Yeah, I had it working for about a day. Everything was working fine on day one. It wasn't until I tried playing a "MD+" game that I started noticing some strange distortion happening with the graphics. Then I had issues accessing certain parts of the menu before the whole thing would just freeze up completely. And then it just stopped booting up completely.

I tried updating the firmware after it started having issues. I was reading the topics created by others that were having problems with their units on this tech support forum and it seemed some folks were able to fix their issues by doing that. I was able to update the firmware (I assume), but I could never get the menu back or any information beyond the Sega startup info to appear on the TV again.

Steven
Posts: 40
Joined: 24 Oct 2019, 18:04
Location: Tokyo

Re: Mega SD cart won't boot to menu (black screen)

28 Nov 2019, 14:37

Is your PSU in good condition? Sometimes even OEM PSUs go bad and need to be replaced with non-OEM ones. That's the only other thing I can think of, but I'm not an engineer, so neodev or Todd would probably be the guys to ask.

I guess you could try updating it again using a different SD card and then trying again. Do other games work? You're getting the TMSS screen the way you should on a TMSS system. I've never had a TMSS system and I don't know much about how that works, but I think I did read something about a TMSS system not reading games properly and crashing after the TMSS screen (and I don't mean with incompatible stuff like Japanese After Burner II), so there is a chance that it could still be the system and not the cart.

retroccn
Posts: 4
Joined: 25 Nov 2019, 17:58

Re: Mega SD cart won't boot to menu (black screen)

28 Nov 2019, 16:34

Steven wrote:
28 Nov 2019, 14:37
Is your PSU in good condition? Sometimes even OEM PSUs go bad and need to be replaced with non-OEM ones. That's the only other thing I can think of, but I'm not an engineer, so neodev or Todd would probably be the guys to ask.

I guess you could try updating it again using a different SD card and then trying again. Do other games work? You're getting the TMSS screen the way you should on a TMSS system. I've never had a TMSS system and I don't know much about how that works, but I think I did read something about a TMSS system not reading games properly and crashing after the TMSS screen (and I don't mean with incompatible stuff like Japanese After Burner II), so there is a chance that it could still be the system and not the cart.

I don't think it's the system or the power supply. Other games boot up no problem. I tried it on two different Model 1 units, a Model 2 unit, and a Sega Nomad and I get the same result.

Steven
Posts: 40
Joined: 24 Oct 2019, 18:04
Location: Tokyo

Re: Mega SD cart won't boot to menu (black screen)

29 Nov 2019, 00:49

No idea. Best thing you can do at this point is email customer service, I think.

retroccn
Posts: 4
Joined: 25 Nov 2019, 17:58

Re: Mega SD cart won't boot to menu (black screen)

29 Nov 2019, 10:47

Steven wrote:
29 Nov 2019, 00:49
No idea. Best thing you can do at this point is email customer service, I think.
Yeah its looking that way. I'll contact them right away and see if I can go about an exchange. Okay, thanks for your help. It's appreciated.

Return to “MegaSD Tech Support”