skins4thewin
Posts: 4
Joined: 19 Jun 2019, 16:26

Problem with placing an order on the site

19 Jun 2019, 16:31

Hi, I have been having a problem with the website for the past two days trying to place a preorder for the Mega SD. Every time I put in my credit card info and hit submit, the page just refreshes as if nothing has happened, no confirmation of payment or anything. It appears the payments are still going through to my card though and I thus had to have them cancelled. I have also been getting error messages every time I try to contact you guys via the Enquiry form on the website, it says that there was an error trying to send the message. Is the website currently broken? Please help, thanks!

User avatar
Todd
Admin
Posts: 574
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Problem with placing an order on the site

19 Jun 2019, 16:41

skins4thewin wrote:
19 Jun 2019, 16:31
Hi, I have been having a problem with the website for the past two days trying to place a preorder for the Mega SD. Every time I put in my credit card info and hit submit, the page just refreshes as if nothing has happened, no confirmation of payment or anything. It appears the payments are still going through to my card though and I thus had to have them cancelled. I have also been getting error messages every time I try to contact you guys via the Enquiry form on the website, it says that there was an error trying to send the message. Is the website currently broken? Please help, thanks!
Most likely your credit card transaction is being declined by your credit card company. I would contact them to find out what is going on.

skins4thewin
Posts: 4
Joined: 19 Jun 2019, 16:26

Re: Problem with placing an order on the site

19 Jun 2019, 16:53

Hm, yesterday I tried to do the transaction 9 times and each one actually ended up charging me to my card, all 9 showed up. I had to get them to cancel the transactions since I wasn't sure what was going on as there was no confirmation and I was charged 9 times. So it most definitely went through but with no confirmation on the website. It might be worth actually looking into. I've never had issues like this with the card before, and today the same thing is happening only the charge is not coming thru on to the card today for some reason. I would really like to place an order for this but it shouldn't be this difficult.

User avatar
Todd
Admin
Posts: 574
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Problem with placing an order on the site

19 Jun 2019, 17:26

I have emailed you back with a detailed account as to why your orders failed.


billybolt31
Posts: 1
Joined: 06 Sep 2019, 02:11

Re: Problem with placing an order on the site

06 Sep 2019, 02:19

hello, I am having a similar issue. I submitted payment and site refreshed and no confirmation. payment didn't appear to show on my credit card. I tried 3 times and all times same thing. contacted my credit card company and no transactions have went through or declined. thank you

User avatar
Todd
Admin
Posts: 574
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Problem with placing an order on the site

06 Sep 2019, 02:59

I would call them back and have them preauthorize an international purchase.


We see this from time to time and it’s the bank that’s needs to allow it.

Return to “Feedback and Suggestions”