tulkas007
Posts: 12
Joined: 06 May 2020, 10:15
Location: Denmark

Very low sound effects on Lords Of Thunder (Sega CD, USA) ?

06 May 2020, 10:21

Hi,

I'm using the MegaSD (latest FW) with my Mega Sg to play Lords Of Thunder (USA Sega CD version) but sounds effect volume is very low (almost gone), even then turning CD music volume all the way down and effect up. Other Mega Drive/Genesis and Mega CD games seems to be fine.

Is this a bug in MegaSD or Mega Sg?

Any suggestions?


Thank you.


/T

Gummy Bear
Posts: 101
Joined: 09 Feb 2019, 22:56

Re: Very low sound effects on Lords Of Thunder (Sega CD, USA) ?

28 May 2020, 19:57

Just tried this game with my Jap MD1 and the sounds are good and loud.

Mega SG strikes again it seems.

tulkas007
Posts: 12
Joined: 06 May 2020, 10:15
Location: Denmark

Re: Very low sound effects on Lords Of Thunder (Sega CD, USA) ?

29 May 2020, 08:59

You are correct, it seems like a Mega Sg issue. I tried the game+Mega SD on my real Mega Drive yesterday, and it seems fine there.
A workaround on Mega Sg is to turn the CD volume down to 20'is and other audio levels to max, but it should not be necessary.

Mega Sg is fantastic and I have had very few issues with it so far. I will report it to them instead, and hope it will be fixed.

Edit: A bit weird though, because it also sounds fine here:

jvesel
Posts: 1
Joined: 01 Jun 2020, 00:36

Re: Very low sound effects on Lords Of Thunder (Sega CD, USA) ?

01 Jun 2020, 00:38

Change your bios. I had this as well. If you use the newest CDX bios with the Mega SD everythibg will sound right. Its fun to see the difference if you try each bios. They each sound different. Some drown out sound effects completely. Some partially. CDX sounds right to me.

Return to “MegaSD Discussion”