arcadegeek
Posts: 4
Joined: 05 Aug 2018, 21:41

NeoSD problem starting games

05 Aug 2018, 21:47

I have two Neo-Geo units. My NeoSD works fine in one of them (Unibios) but my second unit I can get the menu screen but once a game is selected I get a solid blue screen and then nothing. Both units are 5v 3amp power. I am using the same power supply for both. After reading the forums it sounds like there may be a different firmware to address this issues.

arcadegeek
Posts: 4
Joined: 05 Aug 2018, 21:41

Re: NeoSD problem starting games

09 Aug 2018, 06:09

Checking on an update? Anyone have a solution to the earlier model not working correctly?

User avatar
neodev
Posts: 185
Joined: 09 Apr 2018, 14:47

Re: NeoSD problem starting games

10 Aug 2018, 14:13

Does your other board have some mod installed? like reset button leds or triple bios, or something attached to the reset button?
NeoSD drives the reset signal, while other games just read it.
Also do you have a RGB mod installed? we had one user that had a RGB mod and the PSU he was using was not enough to make his AES run (he also had reset led, triple bios and some other mods I can't remember, and they were drawing too much power from the PSU.

Also, the blue screen means No game detected, so maybe the power is just at the limit of neosd and it's not booting, but the AES is. NeoSD has a voltage supervisor that only turns it on when the voltage is in a safe level.

arcadegeek
Posts: 4
Joined: 05 Aug 2018, 21:41

Re: NeoSD problem starting games

12 Aug 2018, 04:12

The one that works has the UniBios and no other mods. The other AES has no mods. Both are 5v 3 amp models. I have swapped power adapters but no change.

arcadegeek
Posts: 4
Joined: 05 Aug 2018, 21:41

Re: NeoSD problem starting games

19 Aug 2018, 01:17

Anything else that can be done to allow the Neo SD to work? I did note that some other posts referenced an earlier firmware fixed the 5v Neo Geo.

Return to “NEOSD and NEOSD Pro AES Tech Support”