squeeb
Posts: 1
Joined: 12 Nov 2020, 11:18

Dreamcast .cdi problems

12 Nov 2020, 12:08

Hi all. I've mentioned this issue recently in the discord but since I haven't made any progress I figured I would make a post here. Before starting, here is the firmware I'm running:

1.03 R02

Essentially, I cannot get any homebrew CDI images to work. I end up at the CD player screen. At first I figured the issue was with the image I was trying, specifically Quake 1 for the DC. I have tried no less than three different ports, all with the same result. I then tried creating my own .cdi image from the source directories...no luck there either.

Some screencaps of the directory structure from these images:

The original Quake 1 port (Titanium Studios)
Image
Hexquake
Image
Radquake
Image

Programs tried when creating the images manually:
  • Boot Dreams 1.0.6c
  • BootMake 1.2
YT guide I followed

Then I decided to try out some of the Doom ports for DC. Again, same issue, whether it was a premade CDI or one I created from scratch. Here is the port (shareware version) if you would like to test: DCDoom-SW-CW-1.4

I feel like I'm missing something here, because surely someone has been able to load a CDI on MODE. And for clarification, I've had zero issues with the rest of my library which is in GDI format (mostly redump).

Thanks in advance!

Return to “MODE Discussion”