overGlow
Posts: 6
Joined: 18 Aug 2020, 02:38

Mega SD not loading firmware or ROMs

18 Aug 2020, 02:49

Just recently received my Mega SD, and I'm experiencing some odd behavior:

1. Mega SD fails when attempting to read a ROM - Genesis either displays the ROM title and freezes, or hard resets.
2. Infinite reboot cycle with latest firmware on memory card - does not occur when firmware is not present on memory card.
3. The TMSS is not a solid white when compared to a normal Genesis cart.

The Mega SD does read the memory card, it drops 3 folders into the root directory: "BUP", "CHEATS", and "STATES". Options menu is available as well, just nothing further. I have tested with 2 memory cards as well.

Any information, recommendations, or troubleshooting requests are welcomed.

User avatar
Todd
Admin
Posts: 1122
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Mega SD not loading firmware or ROMs

18 Aug 2020, 15:31

Need a lot more info.

Console you are using it on, micro sd card make/model and any other details you can provide.
My PMs are disabled. Please send support requests to support(at)terraonion.com.

For real time assistance, please consider joining our very active Discord server: https://discord.gg/JexuJVW

overGlow
Posts: 6
Joined: 18 Aug 2020, 02:38

Re: Mega SD not loading firmware or ROMs

18 Aug 2020, 17:21

Sure thing!

Console - NTSC Genesis Model 1, unsure if its a VA6, VA6.5, or VA6.8, board has CXA1145P and YM2612, image of board: https://imgur.com/a/ASBu9kA
Console PSU is from retrobit: it's testing at 9.5v ~1.2A.

Memory Card - (1) SanDisk 256gb (SDSQUAR-256G-GN6MA) formatted with exFAT. (2) Sandisk 32gb (SDSQXBO-032G-AWCKA) formatted with FAT32.

MegaSD version is 1.01 R12.
Last edited by overGlow on 19 Aug 2020, 19:05, edited 2 times in total.


User avatar
Todd
Admin
Posts: 1122
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Mega SD not loading firmware or ROMs

19 Aug 2020, 16:58

Try setting the Reset type to HARD.
My PMs are disabled. Please send support requests to support(at)terraonion.com.

For real time assistance, please consider joining our very active Discord server: https://discord.gg/JexuJVW

overGlow
Posts: 6
Joined: 18 Aug 2020, 02:38

Re: Mega SD not loading firmware or ROMs

20 Aug 2020, 00:03

All tests posted previously were performed with HARD reset mode active.

https://youtu.be/E6oEz-gDZnU

User avatar
Todd
Admin
Posts: 1122
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Mega SD not loading firmware or ROMs

20 Aug 2020, 16:12

Do you have access to another console to test in? Also a different PSU would be worth trying as these cheap 3rd party ones are notoriously flaky.
My PMs are disabled. Please send support requests to support(at)terraonion.com.

For real time assistance, please consider joining our very active Discord server: https://discord.gg/JexuJVW

overGlow
Posts: 6
Joined: 18 Aug 2020, 02:38

Re: Mega SD not loading firmware or ROMs

21 Aug 2020, 01:37

Unfortunately, no access to another known working Genesis. Ordered a new power supply from Digikey (WSU090-3500-R), will report back with results once available.

overGlow
Posts: 6
Joined: 18 Aug 2020, 02:38

Re: Mega SD not loading firmware or ROMs

27 Aug 2020, 01:59

Solved. New power supply solved the problem. Was able to update firmware and can also load ROMs.

Thanks for the help.

User avatar
Todd
Admin
Posts: 1122
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Mega SD not loading firmware or ROMs

27 Aug 2020, 15:13

Glad to hear that sorted out the issue.
My PMs are disabled. Please send support requests to support(at)terraonion.com.

For real time assistance, please consider joining our very active Discord server: https://discord.gg/JexuJVW

Return to “MegaSD Discussion”