KenToad
Posts: 17
Joined: 15 Feb 2020, 17:49

Re: Lords of Thunder randomly freezing and resetting on Model 1 Genesis

26 Sep 2020, 23:54

Just to update this thread, I finally was able to borrow my friend's model 2 Genesis and I was able to play Lords of Thunder using the water armor all the way through with no issues.

As an aside, my issue with Heimdall's intro cutting short when playing on the Model 1 also stopped happening on the Model 2.

So, either my TMSS "High Definition" Genesis 1 has issues with certain Sega CD games or the Mega SD with Firmware 1.04 r09 has Sega CD compatibility issues with whatever board revision my Genesis is.

jvesel
Posts: 14
Joined: 01 Jun 2020, 00:36

Re: Lords of Thunder randomly freezing and resetting on Model 1 Genesis

27 Sep 2020, 04:28

I had sound issues with Lords using different sega cd bioses. Maybe try a different bios. I ultimately settled on the latest CDX bios. That produced the sound that I thought was most accurate. I know it's a different issue than what you are having but still worth a try.

KenToad
Posts: 17
Joined: 15 Feb 2020, 17:49

Re: Lords of Thunder randomly freezing and resetting on Model 1 Genesis

27 Sep 2020, 17:25

Thanks for the suggestion. Until now, I've tested the recommended 2.00. As far as I know there is no per game setting, so I hadn't even thought to try something else. It's good to know that there are differences and that others are successfully using alternatives. At this point, I've played entirely through the game, so I probably won't go testing much further. It's a fun game, but I've had my couple of hours of entertainment with it, so I'll move onto other games while keeping all this in mind if I run into any more errors using my model 1 Genesis with the Mega SD.

Return to “MegaSD Discussion”