Page 1 of 1

Menu minor graphical glitch

Posted: 22 May 2020, 17:48
by The_A_Drain
Hi guys,

got my serial sorted out, big thanks for that! Loving the MegaSD so far but I noticed a small menu glitch that comes and goes, it's not bad but occasionally it shows up frequently and is a little annoying. Most of the time it's infrequent though.



Top left corner you'll see the cursor briefly appear.

Any idea what might be causing this?
I'm using a Japanese Model 1 Mega Drive with a 1602-05 power supply, testing with original 3-button controller and a 6-button retro-bit controller.

edit:

I'm now seeing much more severe glitches in games.

SG-1000 games, every one I've tried, seems to start up I can hear music and gameplay but no picture, just a black screen.

Mega Drive games, most seem to work ok, but I've had intermittent graphical glitches and occasional freezes. In particular games I've noticed this with are Alien 3, both revisions, Contra Hard Corp and Alien Soldier. In Contra Hard Corp and Alien Soldier I get invisible enemies, in Alien 3 I get flashes of green, tiles mis-placed and eventually a freeze. I'm noticing some kind of small graphical glitch in a lot of games.

It doesn't happen all the time, but it happens often enough to be a big problem.

Some Mega CD games will do the same as the SG-1000, they'll boot up, I see the Mega CD menu, but in-game I just get a black screen.

Re: Menu minor graphical glitch

Posted: 23 May 2020, 11:06
by The_A_Drain
Bump, having more major glitches now.

Re: Menu minor graphical glitch

Posted: 23 May 2020, 18:45
by Todd
Do you have another console to test this on?

Do you another PSU to test with?

Re: Menu minor graphical glitch

Posted: 23 May 2020, 23:45
by The_A_Drain
Unfortunately not yet, I have a Model 2 and PSU, but no AV cables for it.

I have a second Japanese Model 1 and another PSU on the way should be here early next week.

Re: Menu minor graphical glitch

Posted: 26 May 2020, 15:24
by Gummy Bear
This glitch doesn't happen with my JP MD1 VA4.

Re: Menu minor graphical glitch

Posted: 27 May 2020, 12:58
by The_A_Drain
Tested it with another Japanese Mega Drive (VA0) that arrived this morning, and another power supply this time the original Japanese power supply with a stepdown converter.

Works fine on the new one, with either power supply.

So I guess it's a problem with my VA1. Shame.

I can't play SG-1000 games on either, however. I just get a black screen but I do get audio.

edit: Looks like the first one is a VA1 and the second one that works is a VA0. I've cleaned the cartridge slot on the VA1 but I'll try it again.

edit 2: Just tested with a Model 2 PAL console, same result. Works perfectly, confirming an issue with the original VA1 Model 1 I tried. But I also get a black screen with audio for SG-1000 games. Are they supposed to work? I'm not actually sure if they are supported.