Cronambs
Posts: 3
Joined: 01 Dec 2019, 03:10

Buzzing Noise when loading?

01 Dec 2019, 03:36

Hi im getting a buzzing noise everytime the system accesses the SD Card is this normal???

Sounds as if there is a RF leak from accessing the mem card

very noticeable when using Sega CD Games



I recorded this but im not sure you can hear this happening (maybe a little)

SD card is
Kingston 64GB XC

Cronambs
Posts: 3
Joined: 01 Dec 2019, 03:10

Re: Buzzing Noise when loading?

01 Dec 2019, 04:03

Well found the issue, Its my 6 buttion controller was causing issues

Cronambs
Posts: 3
Joined: 01 Dec 2019, 03:10

Re: Buzzing Noise when loading?

02 Dec 2019, 21:31

The Buzzing noise is back but its random, unsure still whats going on but ill check with grounding

User avatar
Mr_Boo_Berry
Posts: 80
Joined: 23 Jun 2019, 12:56

Re: Buzzing Noise when loading?

06 Dec 2019, 11:02

It's possible the Kingston SD card has some sort of SD access noise issue. I have a SanDisk SD card and I don't hear anything like that. Also people have been using Transcend SD cards with the SSDS3 which also has no noise either.

ginoscope
Posts: 5
Joined: 09 Feb 2019, 15:25

Re: Buzzing Noise when loading?

16 Dec 2019, 21:07

I was noticing buzzing noise when I first got my mega sd as well. My issue was I was using a genesis 3 power supply with my genesis 2. Once I switched to the oem supply for the genesis 2 the buzzing went away. I just figured I would post on here in case it can help anyone out who may have a similar issue.

Return to “MegaSD Tech Support”