titchgamer
Posts: 7
Joined: 19 Mar 2019, 22:00

Exception Error: Illega Instruction

28 Aug 2019, 14:34

Hi Guys wondering if someone may be able to help me out.

I have my Neo SD plugged into a MV-1F with a Unibios inside a freshly converted cabinet but I keep getting the following error:

I have thoroughly cleaned the edges of the cart and the board connectors but unsure what else I could do to resolve this issue that keeps poping up within a few mins of starting the machine.

Any pointers appreciated :)

User avatar
Todd
Admin
Posts: 752
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Exception Error: Illega Instruction

28 Aug 2019, 14:56

Do you have another MVS board to test with? Do original games work with your MVS board?

titchgamer
Posts: 7
Joined: 19 Mar 2019, 22:00

Re: Exception Error: Illega Instruction

28 Aug 2019, 15:25

Thanks for the reply Todd,

Well I used the Neo SD in my CMVS before with no issues, And I currently have my original Sengoku running on the MV-1F, Been on for 15 mins or so now with no issues and never noticed any problems when I was running slug on it before I put the NGSD in.

So It seems to be just a problem with the Neo SD on the MV-1F for some reason?

Interestingly though I just put the NGSD back in and run it for 10 mins with no problems at all.....

Have these things been known to cure themselves after a "warm up" period?

I would of liked to of stayed round to play on it longer but I now have to go to work :(

I just have a feeling that its going to throw up the error again the next time I turn the system on for no apparent reason, The only thing that does not "feel right" to me is the cartridge does not seem to slide in as easily as it should so I wonder if thats the problem? But if that is the case why does it work now but not the next time I turn the machine on?

Cheers, Titch.

User avatar
neodev
Posts: 408
Joined: 09 Apr 2018, 14:47

Re: Exception Error: Illega Instruction

28 Aug 2019, 16:04

That looks like a power supply issue. Neosd is more sensitive than normal carts to power noise.

titchgamer
Posts: 7
Joined: 19 Mar 2019, 22:00

Re: Exception Error: Illega Instruction

28 Aug 2019, 17:34

neodev wrote: That looks like a power supply issue. Neosd is more sensitive than normal carts to power noise.
When you say power noise you mean RF interference?

If so that should not be a issue as the mains cables run up the opposite side of the cabinet to all the JAMMA wires.

Unless there is some other thing it could be affected by?

User avatar
neodev
Posts: 408
Joined: 09 Apr 2018, 14:47

Re: Exception Error: Illega Instruction

28 Aug 2019, 19:18

In terms of voltage ripple, or maybe slightly insufficient voltage. As neosd demands a bit more power than a standard cart.

titchgamer
Posts: 7
Joined: 19 Mar 2019, 22:00

Re: Exception Error: Illega Instruction

28 Aug 2019, 19:57

neodev wrote: In terms of voltage ripple, or maybe slightly insufficient voltage. As neosd demands a bit more power than a standard cart.
Ahh ok.

Not sure what I have on it tbh as I set it up with no cartridge in originally but set it at 5.1v bare board.

What should my 5v be set at with a Neo SD plugged in? I can check it tomorrow when I get home.

titchgamer
Posts: 7
Joined: 19 Mar 2019, 22:00

Re: Exception Error: Illega Instruction

29 Aug 2019, 10:34

Ok So I just tried it again this morning and again within 60 seconds illegal instruction error again :(

I have checked the 5V and I have indeed got it set to 5.1V out on the PSU end.


titchgamer
Posts: 7
Joined: 19 Mar 2019, 22:00

Re: Exception Error: Illega Instruction

29 Aug 2019, 12:37

So a bit of a further update, I am hoping this is now fixed but time will tell I guess....

So I decided to rip the board out of the cab and go balls deep with some contact cleaner to see if that helped.

I removed the board and after pulling it out totally I noticed where the IDE connectors are that plug the cart slot into the board were not seated fully, they had sagged in the center slightly (so this may of been the actual problem?)
I pushed them in and then continued with the electrical contact cleaner and then a final scrub with one of those NES cart slot cleaner card things (which I had used a few times before)

Those contacts are now looking like new but to be fair they were not bad to start!

After reinstalling the board and powering it up with the NGSD in the slot I also tuned the PSU so it now has bang on 5V at the Jamma edge going into the board but to be fair it was only a tiny bit low at 4.96V to start with.

Anyway so far so good no errors, Left MOTW playing through its sequence for 15 mins with no issues where before it would always error out within 30 seconds or so.

So with that I am hoping this is fixed and I will have no further issues, Time will tell so assuming all goes well i will report back with good news in a few days :)

Thanks for the assistance thus far guys.

titchgamer
Posts: 7
Joined: 19 Mar 2019, 22:00

Re: Exception Error: Illega Instruction

31 Aug 2019, 23:13

Ok I can confirm that my deep clean etc has not done the job and I am still getting errors :(

So any further ideas guys?

Return to “NEOSD and NEOSD Pro MVS Tech Support”