LamDierg
Posts: 6
Joined: 14 Aug 2019, 16:56

NeoSD MVS fails to boot to menu

19 Aug 2019, 15:26

Literally just arrived. Plugged it into my 1C (which boots official carts just fine), It shows a garbled screen for a few seconds then boots to a dim grey frame that resembles the menu then a grey-bordered popup appears. There is no text anywhere. No indication of what's wrong. I was reading some similar threads and the only thing I found similar was a weak power supply but mine is rated at +5V@5.5A, +12V@2.5A, -5V@500mA which looks like it should be enough. WTF is going on?

LamDierg
Posts: 6
Joined: 14 Aug 2019, 16:56

Re: NeoSD MVS fails to boot to menu

19 Aug 2019, 15:45

OK, I pulled an FZ out of storage (it has color issues) and it booted fine on it. I'm using the same supergun on both. What I'd like to know is what pins should I be looking for that could be loose or something that the NeoSD uses but say KoF 99 doesn't?

Edit: After flashing a game, the cart works in the 1C as that game but the menu is still non-functional. It displays after using the in-game trigger but is garbled, unusable and thinks it's running firmware v0.00

User avatar
Todd
Admin
Posts: 1074
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: NeoSD MVS fails to boot to menu

19 Aug 2019, 16:35

Sounds like maybe a PSU issue. what kind of PSU is it?
My PMs are disabled. Please send support requests to support(at)terraonion.com.

For real time assistance, please consider joining our very active Discord server: https://discord.gg/JexuJVW

LamDierg
Posts: 6
Joined: 14 Aug 2019, 16:56

Re: NeoSD MVS fails to boot to menu

19 Aug 2019, 16:40

It's the PSU internal to the Windy Gaming Supergun. Same PSU works fine with the FZ and the NeoSD so it's something particular with the 1B I have. (I double-checked, it's a 1B not C). The 1B has another issue where the Coin2 signal is inverted and I've traced it back to somewhere on the cartridge daughterboard. It's making me think there's just an issue with the board. Either way, I've got another MVS coming via AliExpress that hopefully has neither issue. Since the NeoSD works perfectly fine in the FZ I'm sure this isn't a Terraonion issue. I'd just like a hint of where to look on the 1B for issues.

Return to “NEOSD and NEOSD Pro Discussion”