itman312
Posts: 9
Joined: 28 Jul 2020, 07:33

Load Error - cannot register

17 Oct 2020, 22:31

I just got my Super SD System 3 today from Stone Age Gamer. Hucard games run fine, but I get a "Load Error!" message whenever I try to boot a CD game. I figured that maybe it needed a firmware update. I got the 7-digit serial number from the bottom of the device and tried to register it in the downloads section of the Terraonion site. It says that the serial number cannot be found.

I don't really care about registering the device, but I just want it to work when booting CD games.

I have an unmodded US Turbografx-16 with original power supply. I am using a Sandisk 32GB microSD card. I am using an HD Retrovision cable, but there are no graphical issues. I made sure the in-game trigger is disabled. My BIOS file name is "[BIOS] TurboGrafx CD Super System Card (USA) (v3.0).pce".

BringerOdeath
Posts: 15
Joined: 30 Dec 2018, 04:28

Re: Load Error - cannot register

19 Oct 2020, 04:48

Same here, tried to put my serial in and it said it was not found and I also bought it from stone age gamer.

User avatar
Todd
Admin
Posts: 1150
Joined: 08 Apr 2018, 22:25
Location: Cincinnati, OH
Contact: Twitter YouTube

Re: Load Error - cannot register

26 Oct 2020, 17:24

Try this: on the SSDS3, go into Options and select version. Use the serial number from there.

It's possible you have a misprinted serial number tag
My PMs are disabled. Please send support requests to support(at)terraonion.com.

For real time assistance, please consider joining our very active Discord server: https://discord.gg/JexuJVW

BringerOdeath
Posts: 15
Joined: 30 Dec 2018, 04:28

Re: Load Error - cannot register

18 Nov 2020, 04:51

It turns out what Todd said is correct. I looked at the serial in menu and the sticker on my stone age game ssds3 was missing the first digit as it was misprinted. The serial from the options menu worked :)

Return to “Super SD System 3 Discussion”