Search found 6 matches

Go to advanced search

by pauljh
09 Oct 2020, 00:06
Forum: NEOSD and NEOSD Pro Discussion
Topic: Timeline for replacement AES SD Pro cases
Replies: 8
Views: 2833

Re: Timeline for replacement AES SD Pro cases

Hi,
I did, 7 days ago, still no reply...
by pauljh
29 Sep 2020, 10:51
Forum: NEOSD and NEOSD Pro Discussion
Topic: Timeline for replacement AES SD Pro cases
Replies: 8
Views: 2833

Re: Timeline for replacement AES SD Pro cases

Do we get an update of the case/spacer problem?< its been over half a year now....
by pauljh
08 Apr 2020, 00:24
Forum: NEOSD and NEOSD Pro Discussion
Topic: Timeline for replacement AES SD Pro cases
Replies: 8
Views: 2833

Timeline for replacement AES SD Pro cases

Hi,
Is there an estimated timeline for when people who can't use the AES SD Pro in the case can expect a working replacement case? No amount of filing etc has helped me at all. Just an estimate is fine..
by pauljh
04 Mar 2020, 01:48
Forum: NEOSD and NEOSD Pro Discussion
Topic: AES SD Pro Green Led, no display
Replies: 5
Views: 2807

Re: AES SD Pro Green Led, no display

Todd wrote:
02 Mar 2020, 17:48
Original games work ok?
Yeap fine AES games, MVS games via a MVSKey and a AES 161 in 1.
by pauljh
01 Mar 2020, 23:42
Forum: NEOSD and NEOSD Pro Discussion
Topic: AES SD Pro Green Led, no display
Replies: 5
Views: 2807

Re: AES SD Pro Green Led, no display

What size and type of micro sd card are you using? A. 16gb, 32gb, 200gb, 256gb Is the micro sd card formatted in fat32? A. Yes Have you tried a different micro sd card to rule out a faulty or incompatible card? A. Yes 4 different cards Did you run neobuilder to convert the neo geo rom files to .neo ...
by pauljh
29 Feb 2020, 21:46
Forum: NEOSD and NEOSD Pro Discussion
Topic: AES SD Pro Green Led, no display
Replies: 5
Views: 2807

AES SD Pro Green Led, no display

Hi,
Sent email about this but no reply yet, hence posting here.

Neo Geo AES SD Pro, didn't work when arrived (no display, green constant LED), checked PSU and was noo official, eventually sourced official PSU, same issue. Have done the spacer fix to no avail.

Please advise.

Go to advanced search