Search found 5 matches

Go to advanced search

by dmp85
05 Sep 2020, 06:15
Forum: MegaSD Discussion
Topic: Save States Not Working
Replies: 2
Views: 507

Re: Save States Not Working

Seems to be working fine again now. Right-clicking the card under 'Properties' and 'Tools' no errors were initially detected by Windows which was where I left it at before making the post. But in going ahead with the actual error scan & repair option it indicated it was repaired when finalized and u...
by dmp85
04 Sep 2020, 07:38
Forum: MegaSD Discussion
Topic: Save States Not Working
Replies: 2
Views: 507

Save States Not Working

I just started having an odd issue with the Mega SD where all of a sudden now save states don't seem to be working anymore. I'm on the latest firmware, never changed any of the settings, tried many games, and two different systems. I also checked if there was anything wrong with the 400gb SanDisk mi...
by dmp85
26 Dec 2019, 08:35
Forum: MegaSD Discussion
Topic: Audio Buzz with Sega Genesis + Framemeister
Replies: 11
Views: 3458

Re: Audio Buzz with Sega Genesis + Framemeister

That's strange. I was actually using that same Model 2 Majesco VA4 initially with the Mega SD and never experienced any buzzing or wavy effects. It did after awhile start to exhibit a different issue, which never happened before and may or may not be related to the Mega SD, where all of the colours ...
by dmp85
12 Sep 2019, 04:36
Forum: Feedback and Suggestions
Topic: I need help to log in Downloads
Replies: 6
Views: 3705

Re: I need help to log in Downloads

I didn't know there was another separate login for the download page as well. Having to create all of these registrations in order to access each individual section on one site is something I've never personally encountered before and find to be a little convoluted to be perfectly honest. But anyway...
by dmp85
11 Sep 2019, 00:14
Forum: Feedback and Suggestions
Topic: I need help to log in Downloads
Replies: 6
Views: 3705

Re: I need help to log in Downloads

I've been having the same issue and I did register when I purchased my copy of the Mega SD. I can login to the site without issue but when I try to login to the download page I'm denied and get the same 'invalid credentials' error message for some reason. I hope someone can help as I would really li...

Go to advanced search